Project

General

Profile

Bug #374

Reloading the webpage of a deleted host

Added by Tony Garcia over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When deleting a node/host directly in the page that shows it's details e.g. http://foreman/hosts/<id> foreman attempts to load again that page(that is now deleted) showing an ugly:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.2.3 (Red Hat) Server at foreman Port 80

History

#1 Updated by Tony Garcia over 8 years ago

It actually happens from the "Delete" or "Destroy" for any host.

#2 Updated by Ohad Levy over 8 years ago

  • Status changed from New to Feedback

I'm not sure I can reproduce this... I've clicked on delete host (in the host show page or index page) and in both cases i got back to the list of hosts.....

can you provide the relevant log entry from your apache or foreman log?

#3 Updated by Tony Garcia over 8 years ago

I think is important to say that I'm currently using foreman as a reporter tool, as I don't use external nodes nor storeconfigs at this moment, also foreman receives most of the reports/facts from external puppetmasters.

Here the log:

Error during failsafe response: closed stream
*** Exception NoMethodError in application (undefined method `each' for nil:NilClass) (process 14968):
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/rack/request_handler.rb:95:in `process_request'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_request_handler.rb:206:in `main_loop'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/railz/application_spawner.rb:376:in `start_request_handler'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/railz/application_spawner.rb:334:in `handle_spawn_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/utils.rb:182:in `safe_fork'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/railz/application_spawner.rb:332:in `handle_spawn_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:351:in `__send__'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:351:in `main_loop'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:195:in `start_synchronously'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:162:in `start'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/railz/application_spawner.rb:213:in `start'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/spawn_manager.rb:261:in `spawn_rails_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/spawn_manager.rb:255:in `spawn_rails_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/spawn_manager.rb:254:in `spawn_rails_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/spawn_manager.rb:153:in `spawn_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/spawn_manager.rb:286:in `handle_spawn_application'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:351:in `__send__'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:351:in `main_loop'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/lib/phusion_passenger/abstract_server.rb:195:in `start_synchronously'
        from /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/bin/passenger-spawn-server:61
[Tue Sep 28 08:29:26 2010] [error] [client 10.14.17.88] Premature end of script headers: hosts, referer: http://foreman.example.com/dashboard/OutOfSync
[ pid=14425 file=ext/apache2/Hooks.cpp:674 time=2010-09-28 08:29:26.303 ]:
  The backend application (process 14968) didn't send a valid HTTP response. It might have crashed during the middle of sending an HTTP response, so please check whether there are crashing problems in your application. This is the data that it sent: [X-Powered-By]

#4 Updated by Ohad Levy over 8 years ago

I can't reproduce this on the latest version (0.1.6rc) can you try it again and confirm if it still happening?

#5 Updated by Tony Garcia over 8 years ago

Not able to reproduce it anymore on 0.1.5, I'll try in 0.1.6rc too.

Thanks.

#6 Updated by Ohad Levy over 8 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF