Project

General

Profile

Bug #3814

Errors when using the CLI

Added by Og Maciel over 5 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Foreman commands (obsolete)
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

  1. hammer user list
    Error: can't convert String into Integer
  1. hammer os list
    Error: undefined method `has_key?' for "":String
  1. hammer user info --id 1
    Error: undefined method `[]' for nil:NilClass

Unfortunately I don't see anything in the logs

foreman-debug-3nRpi.tar.xz foreman-debug-3nRpi.tar.xz 65 KB Og Maciel, 12/04/2013 08:16 PM

History

#1 Updated by Og Maciel over 5 years ago

  1. foreman-debug

    HOSTNAME: xxxxxxxxxxxxxxxxxxxx
    OS: redhat
    RELEASE: Red Hat Enterprise Linux Server release 6.4 (Santiago)
    FOREMAN: 1.4-develop
    RUBY: ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
    PUPPET: 2.7.23

#2 Updated by Dominic Cleal over 5 years ago

rubygem-hammer_cli-0.0.11-1.el6.noarch
rubygem-hammer_cli_foreman-0.0.11-1.el6.noarch
rubygem-foreman_api-0.1.8-1.el6.noarch

#3 Updated by Martin Bacovsky over 5 years ago

  • Category set to Foreman commands (obsolete)
  • Status changed from New to Resolved
  • Assignee set to Martin Bacovsky
  • Target version set to 1.9.3
  • Legacy Backlogs Release (now unused) set to 2

This is caused by new response format in API v2. The fix was merged and will be included in hammer_cli and hammer_cli_foreman >= 0.0.12

Also available in: Atom PDF