Project

General

Profile

Bug #3819

Add proper STI to Operatingsystem subtypes

Added by Greg Sutcliffe over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Rails
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Currently we have each Operatingsystem as a toplevel entity in the codebase, which leads to all sorts of weirdness. We have a lot of STI experience now, so we should redo this properly


Related issues

Related to Foreman - Bug #345: unable to save associated operatingsystemsClosed2010-07-08
Is duplicate of Foreman - Refactor #3962: Operating system children overwrites class methodClosed2014-01-07

History

#1 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #345: unable to save associated operatingsystems added

#2 Updated by Marek Hulán over 5 years ago

  • Is duplicate of Refactor #3962: Operating system children overwrites class method added

#3 Updated by Dominic Cleal over 5 years ago

  • Tracker changed from Refactor to Bug
  • Status changed from New to Duplicate

Also available in: Atom PDF