Project

General

Profile

Actions

Bug #3846

closed

Host Groups are not taken into account in Puppet Classes usage count

Added by Marco De Vitis about 10 years ago. Updated over 9 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

The Configuration / Puppet Classes page shows all available classes and their usage count (in the "Hosts" column), but this count as far as I can tell only includes hosts where the classes are explicitly included, it does not include hosts which inherit the classes by being part of a Host Group where the classes have been assigned.

First of all this is misleading, and makes the usage count potentially useless.

Then it also causes inconsistencies when browsing the GUI: for example you can have a class listed as being used in 0 (zero) hosts, but if you click on the zero you are brought to a page where one or more hosts actually using that class are listed, because they inherit it from the group.


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Bug #844: puppetclass host count does not count hosts though a hostgroupClosedTomer Brisker04/14/2011Actions
Actions #1

Updated by Tomer Brisker over 9 years ago

  • Is duplicate of Bug #844: puppetclass host count does not count hosts though a hostgroup added
Actions #2

Updated by Tomer Brisker over 9 years ago

  • Status changed from New to Duplicate
  • Assignee set to Tomer Brisker

Tracking this issue in #844. Marked as duplicate.

Actions

Also available in: Atom PDF