Project

General

Profile

Bug #3852

Welcome page is no logner visible

Added by Lukas Zapletal about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Yesterday I noticed interesting fact - starting with Foreman 1.3 there is no Welcome page, if you log in after 30+ minutes.

The reason for that is we now registrate one proxy during installation and if everything succeeds and the first host is reported via puppet, host record is created with all necessary records too and welcome page is no longer visible.

Since this is happening everytime and with the default puppet installer configuration, we sholud provide some solution, because this can cause confusion to newcomers.

Maybe it's the time to make the wizard the default thing? But this brings the very same question - should we show the wizard even when the first host entry is created? I think we should.


Related issues

Is duplicate of Foreman - Bug #3163: FQDN/dashboard/help disappears after setupClosed2013-09-27

History

#1 Updated by Dominic Cleal about 6 years ago

  • Is duplicate of Bug #3163: FQDN/dashboard/help disappears after setup added

#2 Updated by Dominic Cleal about 6 years ago

  • Status changed from New to Duplicate

Agreed, though we don't have a wizard at the moment. foreman_setup's the closest, and I would like to make this more "default" (once we've got plugin installer support in #3308).

Also available in: Atom PDF