Project

General

Profile

Feature #3861

Better logging/reporting/audit of provisioning including contents

Added by Lukas Zapletal over 7 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Audit Log
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Currently reports only contains Puppet reports. It might be interesting to extend them and allow reporting of provision information - host was booted, anaconda started with installation etc. Along with that, we should be able to provide extra details for a report line, where we could store whole template generated (only visible to users with permissions), which could make investigation easier.


Related issues

Related to Discovery - Feature #3862: Audit discovery of new host and provision actionsClosed2013-12-12
Related to Foreman - Feature #746: Generate all the Host template when click on Build to avoid errors during installationClosed2011-03-15
Related to Foreman - Feature #22493: Add new logging options to integrate with logging-journald gemClosed2018-02-02
Is duplicate of Foreman - Feature #13674: Provisioning Templates successful build time stampDuplicate2016-02-11

History

#1 Updated by Lukas Zapletal over 7 years ago

  • Related to Feature #3862: Audit discovery of new host and provision actions added

#2 Updated by Lukas Zapletal almost 6 years ago

  • Related to Feature #746: Generate all the Host template when click on Build to avoid errors during installation added

#3 Updated by Lukas Zapletal almost 6 years ago

Everytime we render a template, we should put it's contents to audit as well.

#4 Updated by Lukas Zapletal almost 4 years ago

  • Is duplicate of Feature #13674: Provisioning Templates successful build time stamp added

#5 Updated by Lukas Zapletal almost 4 years ago

  • Status changed from New to Duplicate

#6 Updated by Lukas Zapletal almost 4 years ago

  • Subject changed from Better logging/reporting/audit of provisioning to Better logging/reporting/audit of provisioning including contents
  • Bugzilla link set to 1299024

Including whole content of provisioning templates raises question around security (there's root password). We need to solve that first.

#7 Updated by Dominic Cleal almost 4 years ago

Why are both this and #13674 marked as duplicates? Are they duplicates of a third issue number?

#8 Updated by Lukas Zapletal almost 4 years ago

  • Status changed from Duplicate to New

It was marked as duplicate as mistake, this is a valid RFE.

#9 Updated by Lukas Zapletal almost 3 years ago

  • Bugzilla link deleted (1299024)

#10 Updated by Lukas Zapletal almost 3 years ago

  • Related to Feature #22493: Add new logging options to integrate with logging-journald gem added

#11 Updated by Lukas Zapletal almost 3 years ago

  • Assignee set to Lukas Zapletal
  • Status changed from New to Resolved
  • Category set to Audit Log

This was implemented as #22493 - all templates contents can be configured to appear in production.log or syslog/journald and this can be further integrated with 3rd party logging solutions. Logger named "blob" must be enabled and the following fields are available: template_digest, template_name, template_context, template_host_name and template_host_id.

Also available in: Atom PDF