Project

General

Profile

Feature #3868

Allow users to turn on pagination by e.g. per_page=0

Added by Martin Bacovsky over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

It would be nice to have some option to turn off pagination.
Today per_page=0 returns pages with no items indefinitely so it would be nice candidate for this feature.

Ability to turn off pagination cleanly would be helpful for scripting with API (IMO majority of API users).


Related issues

Is duplicate of Foreman - Feature #3652: Add explicit way for API consumers to specifiy all pages in an index requestDuplicate2013-11-14

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Feature #3652: Add explicit way for API consumers to specifiy all pages in an index request added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF