Project

General

Profile

Bug #3871

Foreman 1.3.1: Adding a new smart class parameter override fails if there is an existing match on an hostgroup that don't exist.

Added by Peter Gustafsson over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Smart Variables
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hi,

Adding a new smart class parameter override from the Smart Class Parameter page fails if there is an existing match on an hostgroup that don't exist.
It fails silent so if there is many matches defined, it is a tedious task to find the failing match.
This situation can occur if you rename a host group that there is matches on.

Br, Peter


Related issues

Related to Foreman - Bug #3206: Prevent any user including admin from creating lookup_value with fdqn= to host that doesn't existClosed2013-10-06
Related to Foreman - Bug #3889: No validation errors for nested class parameters on Puppet class edit pageClosed2013-12-16
Is duplicate of Foreman - Bug #2866: Changing a hostgroup name doesn't update associated Smart Variable matchersClosed2013-07-31

History

#1 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #3206: Prevent any user including admin from creating lookup_value with fdqn= to host that doesn't exist added

#2 Updated by Dominic Cleal over 5 years ago

  • Category changed from Puppet integration to Smart Variables

We should fix the issue with renaming host groups I think, also re-parenting/nesting.

#3 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #3889: No validation errors for nested class parameters on Puppet class edit page added

#4 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #2866: Changing a hostgroup name doesn't update associated Smart Variable matchers added

#5 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF