Project

General

Profile

Actions

Bug #3960

closed

Could not find 'fastercsv' gem with Fedora 19 RPMs

Added by Dominic Cleal about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Hammer core
Target version:
Difficulty:
Triaged:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

The hammer command is failing with the F19 RPMs as it's trying to load fastercsv according to the gemspec. Since this is a Ruby 2.0 platform, it's not actually needed, but the gemspec doesn't specify this.

not ok 15 check smart proxy is registered
# (in test file /usr/bin/fb-install-foreman.bats, line 135)
# /usr/share/rubygems/rubygems/dependency.rb:296:in `to_specs': Could not find 'fastercsv' (>= 0) among 94 total gem(s) (Gem::LoadError)
#     from /usr/share/rubygems/rubygems/specification.rb:1209:in `block in activate_dependencies'
#     from /usr/share/rubygems/rubygems/specification.rb:1198:in `each'
#     from /usr/share/rubygems/rubygems/specification.rb:1198:in `activate_dependencies'
#     from /usr/share/rubygems/rubygems/specification.rb:1180:in `activate'
#     from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:48:in `gem'
#     from /usr/bin/hammer:22:in `<main>'
Actions #1

Updated by Dominic Cleal about 10 years ago

  • Status changed from New to Closed
  • Assignee set to Dominic Cleal
  • Target version set to 1.9.3
  • translation missing: en.field_release set to 2

Fixed in rubygem-hammer_cli-0.0.14-2.fc19.

Actions #2

Updated by Dominic Cleal about 10 years ago

The commit associated to this issue was actually #3869.

Actions

Also available in: Atom PDF