Project

General

Profile

Refactor #3962

Operating system children overwrites class method

Added by Marek Hulán over 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Rails
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I think overwriting #class method is wrong (maybe except proxy objects). It's hard to debug problems and it causes unexpected problems. I propose to use #becomes instead.


Related issues

Related to Foreman - Bug #345: unable to save associated operatingsystemsClosed2010-07-08
Has duplicate Foreman - Bug #3819: Add proper STI to Operatingsystem subtypesDuplicate2013-12-05

Associated revisions

Revision 95a66717 (diff)
Added by Marek Hulán over 5 years ago

Fixes #3962 - Refactor class overwriting

Revision 07c98cde (diff)
Added by Marek Hulán over 5 years ago

Fixes wrong os family caused by 'becomes' refs #3962

History

#1 Updated by Marek Hulán over 5 years ago

  • Has duplicate Bug #3819: Add proper STI to Operatingsystem subtypes added

#2 Updated by Marek Hulán over 5 years ago

  • Status changed from Assigned to Ready For Testing

#3 Updated by Marek Hulán over 5 years ago

  • Related to Bug #345: unable to save associated operatingsystems added

#4 Updated by Dominic Cleal over 5 years ago

  • Category set to Rails
  • Target version set to 1.9.2
  • Legacy Backlogs Release (now unused) set to 2

#5 Updated by Marek Hulán over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF