Project

General

Profile

Bug #4057

Foreman won't load VM's from vSphere 5

Added by Katello Issue Migration over 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

From the nightlies as of this posting, I get this error when trying to load VM's via:
'Provisioning -> Compute Resources -> Virtual Machines'
```
There was an error listing VMs: undefined method `state' for #<FogExtensions::Vsphere::MiniServer:0x00000008eafe40>
```
No other errors in the logs:
```

Started GET "/foreman/compute_resources/1-vmware-test/vms" for 127.0.0.1 at 2013-09-12 15:18:26 -0700
Processing by ComputeResourcesVmsController#index as HTML
Parameters: {"compute_resource_id"=>"1-vmware-test"}
Rendered compute_resources_vms/index/_vmware.html.erb (2.3ms)
Rendered compute_resources_vms/index.html.erb within layouts/application (2.8ms)
Rendered compute_resources_vms/_error.html.erb (0.1ms)
Completed 200 OK in 48600ms (Views: 0.4ms | ActiveRecord: 0.0ms)
```

Created: dazole on September 12, 2013 22:21 +00:00
Imported from https://api.github.com/repos/Katello/katello/issues/2936


Related issues

Is duplicate of Foreman - Bug #3072: Vmware: error listing VMsClosed2013-09-11

History

#1 Updated by Angelo Lisco over 8 years ago

This was fixed in Foreman 1.3.0
http://projects.theforeman.org/issues/3072

#2 Updated by Dominic Cleal over 8 years ago

  • Is duplicate of Bug #3072: Vmware: error listing VMs added

#3 Updated by Dominic Cleal over 8 years ago

  • Status changed from New to Duplicate

Thanks!

#4 Updated by Eric Helms almost 8 years ago

  • Triaged set to Yes

#5 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#6 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF