Project

General

Profile

Bug #4071

Package#autocomplete_name is not working for page_size

Added by Katello Issue Migration over 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

The results from ElasticSearch for Package#autocomplete_name search are limited automatically to 10 (10 is the default search results size in ElasticSearch) so any number more than 10 probably won't work. Another problem is that we unique-ify the results after the query so supposing we get back 10 results that all have the same name, we only return 1 result. We need to have ElasticSearch both select distinct results and limit the results to 10.

Created: daviddavis on July 17, 2013 18:30 +00:00
Imported from https://api.github.com/repos/Katello/katello/issues/2645


Related issues

Is duplicate of Katello - Bug #4074: Content View Package Filter rules will only filter up to 10 itemsResolved2014-01-16

History

#1 Updated by Eric Helms almost 8 years ago

  • Category set to 111
  • Difficulty set to easy
  • Triaged set to Yes

#2 Updated by Eric Helms almost 8 years ago

  • Is duplicate of Bug #4074: Content View Package Filter rules will only filter up to 10 items added

#3 Updated by Eric Helms almost 8 years ago

  • Status changed from New to Duplicate

#4 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#5 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#6 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF