Project

General

Profile

Bug #4219

Orgs disabled on domain edit page when in org context

Added by Dominic Cleal over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Organizations and Locations
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Steps to reproduce:
1. create an organisation
2. create a domain with the above organisation selected
3. change to the organisation context context
4. edit the domain, click the organisations tab

Actual results:
organisations list is greyed out

Expected results:
organisations can be selected

(https://bugzilla.redhat.com/show_bug.cgi?id=1052332)


Related issues

Related to Foreman - Feature #4002: disable locations/organizations on edit domain, subnet, compute_resource, etc. if usedClosed2014-01-13

Associated revisions

Revision e611a26c (diff)
Added by Joseph Magen over 5 years ago

fixes #4605 - users should not be able to de-select disabled items in multi-select widget

fixes #4618 - added back tooltips inherited, used, and used in location / organization edit

fixes #4219 - do not disable current organization/location on multi-select

History

#1 Updated by Dominic Cleal over 5 years ago

  • Target version set to 1.9.1

#2 Updated by Og Maciel over 5 years ago

I am having a hard time reproducing this. I created a NY Data Store organization and 3 new domains. Somehow all 3 domains were automatically associated to my existing ACME Corporation, so I edited them to have no organizations. I then shifted the context to NY Data Store and clicked on Domains. No domains are visible...

#3 Updated by Dominic Cleal over 5 years ago

  • Description updated (diff)

#4 Updated by Dmitri Dolguikh over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Dmitri Dolguikh

#5 Updated by Dmitri Dolguikh over 5 years ago

  • Status changed from Assigned to Ready For Testing

#6 Updated by Dominic Cleal over 5 years ago

  • Status changed from Ready For Testing to Feedback

Dmitri, I think it's now safe to close or reject or resolve this issue since the implementation changed in #3912. Could you confirm please?

#7 Updated by Dominic Cleal over 5 years ago

  • Related to Feature #4002: disable locations/organizations on edit domain, subnet, compute_resource, etc. if used added

#8 Updated by Dmitri Dolguikh over 5 years ago

  • Target version changed from 1.9.1 to 1.9.0

#9 Updated by Dmitri Dolguikh over 5 years ago

  • Status changed from Feedback to Closed

#10 Updated by Dominic Cleal over 5 years ago

  • Legacy Backlogs Release (now unused) set to 4

Also available in: Atom PDF