Project

General

Profile

Bug #4237

Cannot require rgen/metamodel in foreman-proxy with 1.4.0 on Fedora 19 (clean install)

Added by James Read over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi folks,

I installed a fresh Fedora 19 virtual machine for Foreman, fully yum updated. I downloaded the foreman-release.rpm using the link provided in the documentation (1.4.0) and installed using no special arguments with the foreman-installer (1.4.0 1.fc19, Build date Wed 29 Jan 2014 02:11:32 PM GMT).

PostgreSQL failed to start from the puppet installer, so I bounced the service manually and it worked fine. foreman-proxy also failed to start, but I cannot bounce this service manually. I get this error;

Feb 3 13:36:50 localhost smart-proxy15290: /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- rgen/metamodel_builder (LoadError)

Attached /var/log/messages and foreman-installer.log for your viewing pleasure. :)

foreman-installer.log foreman-installer.log 478 KB James Read, 02/03/2014 01:54 PM
var_log_messages var_log_messages 69.9 KB James Read, 02/03/2014 01:54 PM

History

#2 Updated by Dominic Cleal over 8 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) deleted (2)

This is a bug in the Fedora puppet package, which will soon be fixed: https://bugzilla.redhat.com/show_bug.cgi?id=1051613.

In the meantime, you can install "rubygem-rgen" manually or use the Puppet Labs packages from yum.puppetlabs.com.

Also available in: Atom PDF