Project

General

Profile

Bug #4291

Commands should use hyphens instead of underscores

Added by Tomáš Strachota over 8 years ago. Updated over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Foreman commands (obsolete)
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Katello plugin uses hyphens to divide command-name-words whereas foreman uses_underscores. We should be consistent and majority of users prefers hyphens.


Related issues

Related to Hammer CLI - Bug #4292: Create guidelines for command and option namingRejected
Related to Katello - Bug #4404: Rename lifecycle-environment to lifecycle_environment for consistencyRejected2014-02-20
Is duplicate of Hammer CLI - Bug #4697: Make command names consistent in HammerClosed2014-03-19

History

#1 Updated by Tomáš Strachota over 8 years ago

  • Related to Bug #4292: Create guidelines for command and option naming added

#2 Updated by David Davis over 8 years ago

Also, we should update the subcommands too like add_... and remove_...

#3 Updated by Dominic Cleal over 8 years ago

  • Related to Bug #4404: Rename lifecycle-environment to lifecycle_environment for consistency added

#4 Updated by Og Maciel over 8 years ago

This change will cause our CLI automation to stop working (easily fixable though), so I'd like to prepare for it and know when should QE expect this to be done?

#5 Updated by Tomáš Strachota over 8 years ago

  • Related to Bug #4697: Make command names consistent in Hammer added

#6 Updated by Tomáš Strachota over 8 years ago

  • Related to deleted (Bug #4697: Make command names consistent in Hammer)

#7 Updated by Tomáš Strachota over 8 years ago

  • Is duplicate of Feature #469: Sandbox kickstart rendering added

#8 Updated by Tomáš Strachota over 8 years ago

  • Is duplicate of deleted (Feature #469: Sandbox kickstart rendering)

#9 Updated by Tomáš Strachota over 8 years ago

  • Is duplicate of Bug #4697: Make command names consistent in Hammer added

#10 Updated by Tomáš Strachota over 8 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF