Project

General

Profile

Bug #4320

Error when syncing CentOS 5.10 repo

Added by Dan Mashal over 6 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Katello/Foreman 1.5.0

CentOS 6.5, Fedora 19 and Fedora 20 work fine.

When attempting to sync CentOS 5.10 from the Stanford mirror I get the following:

Failed to perform additional action Fort::Actions::RepositoryCreateAction: uninitialized constant Fort::Actions::RepositoryCreateAction::Repository

Filing this bug as per irc convo with ohadlevy

production.log production.log 656 KB Dan Mashal, 02/12/2014 07:34 AM
production.log-20140212 production.log-20140212 193 KB Dan Mashal, 02/12/2014 07:34 AM
jobs-startup.log-20140212 jobs-startup.log-20140212 471 Bytes Dan Mashal, 02/12/2014 07:35 AM

History

#1 Updated by Ohad Levy over 6 years ago

  • Project changed from Foreman to Katello

do you have any more info in the logs? a tracelog would be very useful.
also, which version of katello are you using?

#2 Updated by Dan Mashal over 6 years ago

Katello/Foreman 1.5.0 from git snapshot.

pulp.log http://paste.fedoraproject.org/76454/90095139
nectar.log http://paste.fedoraproject.org/76455/90126139

Other logs attached.

Let me know if you need anything else.

#3 Updated by Mike McCune over 6 years ago

thanks for the logs, looks like it was caused by:

Rolling back due to a problem: []
503 Service Unavailable: {"http_request_method": "POST", "exception": null, "error_message": "Operation timed out after: 0:00:20", "_href": "/pulp/api/v2/repositories/Dan_Corp-CentOS_5-CentOS_5_10/importers/yum_importer/schedules/sync/", "http_status": 503, "traceback": null, "timeout": "0:00:20"}

how much ram do you have setup on your system running Katello?

#4 Updated by Dan Mashal over 6 years ago

Per our conversation on IRC I upgraded the VM to 8GB but it didn't make a difference.

When I point change the repository url from

http://mirror.stanford.edu/yum/pub/centos/5.10/os/

to

http://mirror.stanford.edu/yum/pub/centos/5.10/os/x86_64

the repo is now syncing.

#5 Updated by Dominic Cleal over 6 years ago

  • Legacy Backlogs Release (now unused) deleted (4)

#6 Updated by Eric Helms over 6 years ago

  • Category set to 91
  • Triaged set to Yes

#7 Updated by Eric Helms about 6 years ago

  • Status changed from New to Resolved

The offending code no longer exists in the way the bug mentions. If you run into this with the current code please re-open.

#8 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF