Project

General

Profile

Bug #4336

Hammer facts by --name doesn't work

Added by Daniel Lobato Garcia over 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hammer core
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

hammer host facts --id myhost

works well, returns the host facts.

hammer host facts --name myhost

doesn't find any fact or claims that --name is empty.

History

#1 Updated by Marc-Christian Petersen over 5 years ago

since hammer CLI of Foreman 1.4 I get this:

hammer host facts --name foobar
Error: At least one of options --id, --name is required
See: 'hammer host facts --help'

when I use --id, I get the same message as above.

when using hammer 0.1.0-1 from Foreman 1.5rc1 I get:

hammer host facts --id 1
No data.

--name does not work there too.

The host has facts of course :)

#2 Updated by Kamjar Gerami almost 4 years ago

Works fine for both methods using :

foreman-1.9.2-1.el7.noarch
rubygem-hammer_cli_foreman-0.3.0-1.el7.noarch

#3 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Resolved

Confirmed, thanks Kamjar.

Also available in: Atom PDF