Project

General

Profile

Bug #4348

Host group parameters tab doesn't show inherited parameters

Added by Dominic Cleal over 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When viewing the parameters tab of a child/nested host group, the parameters inherited from the parent host group aren't shown. ("Global" parameters, not smart class parameters.)


Related issues

Is duplicate of Foreman - Bug #4596: cannot change parent of hostgroupClosed2014-03-08
Blocks Foreman - Tracker #4470: Usability of parameters and overridesNew

History

#1 Updated by David Patterson about 5 years ago

I'd like to put in my vote to have this fixed, please :)

#2 Updated by Dominic Cleal about 5 years ago

  • Blocks Tracker #4470: Usability of parameters and overrides added

#3 Updated by Ori Rabin almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Ori Rabin

#4 Updated by Ori Rabin almost 5 years ago

  • Status changed from Assigned to Need more information

Can I get an example?

if I add a smart variable to a puppetclass that is inherited it will appear in the child hostgroup.
if I add a global parameter to a hostgroup it will appear in the child hostgroup.

what isn't inherited correctly?

#5 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Bug #4596: cannot change parent of hostgroup added

#6 Updated by Dominic Cleal almost 5 years ago

  • Status changed from Need more information to Duplicate

Fixed via #4596 for Foreman 1.7.0.

Also available in: Atom PDF