Project

General

Profile

Feature #4351

Global user permissions need to be delivered to angular pages

Added by Thomas McKay over 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Currently permissions are embedded in individual results objects, however this does not satisfy global or complex permissions for pages.

For example, before there are any activation keys the "create" button needs to be disabled based upon current user's perms.

Another example would be a user viewing an activation key but not having permission to view or edit subscriptions. The subs perms need to be delivered in this case.


Related issues

Related to Katello - Feature #5217: As a user, I should have CRUD permissions for all entities that are exposed to me.Closed2014-04-16
Is duplicate of Katello - Feature #5503: Available UI interactions should reflect a user's permissionsClosed2014-04-29

History

#1 Updated by Thomas McKay over 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Thomas McKay

Will embed in /engines/bastion/app/views/bastion/layouts/application.html.haml

https://github.com/Katello/katello/blob/master/engines/bastion/app/views/bastion/layouts/application.html.haml#L17

#2 Updated by Mike McCune about 8 years ago

  • Triaged set to Yes

#3 Updated by Mike McCune about 8 years ago

  • Triaged deleted (Yes)

#4 Updated by Mike McCune about 8 years ago

  • Triaged set to Yes

#5 Updated by Walden Raines about 8 years ago

  • Assignee changed from Thomas McKay to Walden Raines

#6 Updated by Walden Raines about 8 years ago

  • Related to Feature #5217: As a user, I should have CRUD permissions for all entities that are exposed to me. added

#7 Updated by Walden Raines almost 8 years ago

  • Status changed from Assigned to Duplicate

Duplicate of #5503.

#8 Updated by Walden Raines almost 8 years ago

  • Is duplicate of Feature #5503: Available UI interactions should reflect a user's permissions added

#9 Updated by Walden Raines almost 8 years ago

  • Status changed from Duplicate to New
  • Priority changed from High to Normal

This is not an exact duplicate of #5503.

We need to figure out a way to allow more complex, cross resource permissions.

#10 Updated by Walden Raines almost 8 years ago

  • Tracker changed from Bug to Feature

#11 Updated by Walden Raines almost 8 years ago

  • Is duplicate of deleted (Feature #5503: Available UI interactions should reflect a user's permissions)

#12 Updated by Walden Raines almost 8 years ago

  • Related to Feature #5503: Available UI interactions should reflect a user's permissions added

#13 Updated by Walden Raines almost 8 years ago

  • Status changed from New to Duplicate

Taken care of in #5503.

#14 Updated by Walden Raines almost 8 years ago

  • Related to deleted (Feature #5503: Available UI interactions should reflect a user's permissions)

#15 Updated by Walden Raines almost 8 years ago

  • Is duplicate of Feature #5503: Available UI interactions should reflect a user's permissions added

#16 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#17 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#18 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF