Project

General

Profile

Bug #4354

Can't modify compute resource if the host has been changed

Added by Andrew Lau over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources
Target version:
-
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

If for example the ovirt-engine URL has changed, when the user goes to press "edit" foreman will error with "No route to host - connect(2)"

I believe it's doing some test to check the connection exists before allowing any modifications. The only work around seems to be modifying the database directly or putting the ovirt-engine back on the same URL foreman was expecting.

I've had a look at the source, and I believe I know where the culprit lies but I'm not familiar with ruby enough to make the changes.


Related issues

Is duplicate of Foreman - Bug #3567: Editing an oVirt compute resource can throw errors loading quotes while loading pageClosed2013-11-04

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #3567: Editing an oVirt compute resource can throw errors loading quotes while loading page added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF