Project

General

Profile

Bug #4419

[usability] override parameters UI workflow

Added by Ohad Levy over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When trying to override a parameter with a large set of parameters the user needs to scroll up and down many times.

I would suggest to override the value in place, and have a hover / to show the original value with an indicator that it has been overridden.

wireframes: https://dl.dropboxusercontent.com/u/5892944/Foreman-Parameters-2015-04-16.pdf


Related issues

Related to Foreman - Feature #4205: wizard for editing class parameters of a hostNew2014-01-28
Related to Foreman - Tracker #4470: Usability of parameters and overridesNew

Related to Foreman - Tracker #10467: Parameter UI improvements in host and hostgroup formsNew2015-05-11

Related to Foreman - Feature #11300: Auto complete Smart Variable filters by typeNew2015-08-05
Related to Foreman Remote Execution - Bug #11722: Selecting input type on newly added fields doesn't work with Foreman nightlyClosed2015-09-08

Associated revisions

Revision 09ce8a63 (diff)
Added by Ori Rabin about 4 years ago

Fixes #4419 - rearranging smart class parameters edit form

Revision 3dcfa117 (diff)
Added by Dominic Cleal about 4 years ago

refs #4419 - add underscore-rails to assets

History

#1 Updated by Lukas Zapletal over 5 years ago

The same for Templates when there are lots of templates. You need to scroll here and there.

#2 Updated by Ohad Levy over 5 years ago

Lukas Zapletal wrote:

The same for Templates when there are lots of templates. You need to scroll here and there.

which templates? listing templates? editing templates? templates under the host edit?

#3 Updated by Lukas Zapletal over 5 years ago

Provisioning templates, after import from community templates.

But now I see I have "per page" set to 999. Could be the cause for this.

#4 Updated by Dominic Cleal over 5 years ago

  • Related to Feature #4205: wizard for editing class parameters of a host added

#5 Updated by Dominic Cleal over 5 years ago

  • Related to Tracker #4470: Usability of parameters and overrides added

#6 Updated by Ohad Levy about 5 years ago

  • Assignee deleted (Amos Benari)

#7 Updated by Tom Caspy over 4 years ago

  • Description updated (diff)

#8 Updated by Tom Caspy over 4 years ago

  • Related to Tracker #10467: Parameter UI improvements in host and hostgroup forms added

#9 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2398 added
  • Pull request deleted ()

#10 Updated by Dominic Cleal about 4 years ago

  • Related to Feature #11300: Auto complete Smart Variable filters by type added

#11 Updated by Dominic Cleal about 4 years ago

  • Assignee set to Ori Rabin
  • Legacy Backlogs Release (now unused) set to 63

#12 Updated by Ori Rabin about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#13 Updated by Marek Hulán almost 4 years ago

  • Related to Bug #11722: Selecting input type on newly added fields doesn't work with Foreman nightly added

Also available in: Atom PDF