Project

General

Profile

Actions

Feature #4426

closed

Allow changing/setting of organisation and location in the "Provision Host" screen

Added by Anonymous over 10 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Category:
Discovery plugin
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

When using orgs and locs, the way to set these values is to select a host on the "Discoverred Hosts" screen, then the Menu "Select Action" aapears and there org and loc can be set. It would be much nicer if this could be set in the "New Host" screen one get's dropped into after clicking "Provision"


Related issues 11 (2 open9 closed)

Related to Foreman - Bug #2033: Cannot assign a host to an orgClosedJoseph Magen12/11/2012Actions
Related to Discovery - Bug #8148: Allow editing taxonomy on Provision Host formNew10/29/2014Actions
Related to Discovery - Feature #11457: Add taxonomy to discovery rulesClosed08/24/2015Actions
Related to Discovery - Refactor #14035: Redesign discovered hostNew03/03/2016Actions
Related to Discovery - Bug #15469: Editing an ordinary host gives undefined method `[]' for nil:NilClassClosedShimon Shtein06/20/2016Actions
Related to Discovery - Bug #15732: Unit test failure for the new modal formClosedShimon Shtein07/19/2016Actions
Related to Discovery - Bug #15735: Subnet is not selected with domainRejected07/19/2016Actions
Related to Discovery - Feature #15777: Provision action on the detail of a discovered host should use modal formClosedOri Rabin07/22/2016Actions
Related to Discovery - Bug #15793: Quick provisioning does not set build modeClosedLukas Zapletal07/22/2016Actions
Is duplicate of Discovery - Bug #11564: Unable to Change location for Discovered Hosts in WebUIDuplicateOhad Levy08/25/2015Actions
Is duplicate of Discovery - Bug #11605: Discovered hosts API does not allow setting Organization/LocationDuplicate08/28/2015Actions
Actions #1

Updated by Dominic Cleal about 9 years ago

  • Related to Bug #2033: Cannot assign a host to an org added
Actions #2

Updated by Lukas Zapletal almost 9 years ago

  • Category set to Discovery plugin
  • Priority changed from Low to High

In 1.9 the workaround does not work anymore, there is no way of setting Org/Loc either manually or via rules. Bumping priority.

Actions #3

Updated by Lukas Zapletal almost 9 years ago

  • Subject changed from Allow changing/setting of organisation and location in the "New Host" screen to Allow changing/setting of organisation and location in the "Provision Host" screen

For the record, this is because we use "Host/edit" action which turns off org/loc selectors. Existing hosts cannot change taxonomy.

Actions #4

Updated by Lukas Zapletal almost 9 years ago

  • Bugzilla link set to 1245642
Actions #5

Updated by Lukas Zapletal almost 9 years ago

  • Related to Bug #8148: Allow editing taxonomy on Provision Host form added
Actions #6

Updated by Lukas Zapletal almost 9 years ago

Actions #7

Updated by Lukas Zapletal almost 9 years ago

WORKAROUND: Org/Loc of discovered hosts can be changed via mass actions - select one or more discovered hosts via checkboxes on the left, then click on Select Action -> Assign Organization.

Actions #8

Updated by Lukas Zapletal almost 9 years ago

  • Is duplicate of Bug #11564: Unable to Change location for Discovered Hosts in WebUI added
Actions #9

Updated by The Foreman Bot almost 9 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_discovery/pull/211 added
  • Pull request deleted ()
Actions #10

Updated by Lukas Zapletal almost 9 years ago

  • Bugzilla link changed from 1245642 to 1257607
Actions #11

Updated by Lukas Zapletal almost 9 years ago

Implement API/CLI for this as well

Actions #12

Updated by Lukas Zapletal almost 9 years ago

  • Is duplicate of Bug #11605: Discovered hosts API does not allow setting Organization/Location added
Actions #13

Updated by The Foreman Bot over 8 years ago

  • Assignee set to Lukas Zapletal
Actions #14

Updated by Lukas Zapletal over 8 years ago

Actions #15

Updated by Lukas Zapletal over 8 years ago

  • Status changed from Ready For Testing to New
  • Priority changed from High to Normal
  • Pull request deleted (https://github.com/theforeman/foreman_discovery/pull/211)

Instead of creating more and more hacks to recycle Edit Host form, we should do proper solution. Created #14035 for this.

Actions #16

Updated by The Foreman Bot about 8 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_discovery/pull/273 added
Actions #17

Updated by Shimon Shtein about 8 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #18

Updated by Lukas Zapletal about 8 years ago

  • Related to Bug #15469: Editing an ordinary host gives undefined method `[]' for nil:NilClass added
Actions #19

Updated by Lukas Zapletal almost 8 years ago

  • Related to Bug #15732: Unit test failure for the new modal form added
Actions #20

Updated by Lukas Zapletal almost 8 years ago

  • Related to Bug #15735: Subnet is not selected with domain added
Actions #21

Updated by Lukas Zapletal almost 8 years ago

  • Related to Feature #15777: Provision action on the detail of a discovered host should use modal form added
Actions #22

Updated by Lukas Zapletal almost 8 years ago

  • Related to Bug #15793: Quick provisioning does not set build mode added
Actions

Also available in: Atom PDF