Project

General

Profile

Bug #4554

Editing filter on namespaced resource type fails with undefined method `foreman_setup/provisioners_path'

Added by Dominic Cleal over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

In foreman_setup, a permission is added for ForemanSetup::Provisioner, but when editing a filter referencing this type, you get the following error as it tries to determine the path for autocompletion:

ActionView::Template::Error (undefined method `foreman_setup/provisioners_path' for #<#<Class:0x00000007aebf30>:0x0000000855db08>):
    45: 
    46:         <%= autocomplete_f f, :search,
    47:                            :disabled => f.object.unlimited?,
    48:                            :path => resource_path(f.object.resource_type), :control_group_id => 'search_group' %>
    49:       </div>
    50:     </div>
    51: 
  app/helpers/filters_helper.rb:20:in `resource_path'
  app/views/filters/_form.html.erb:48:in `block in _b45b2ae2fba8a33ed854c14ac1956876'
  app/helpers/layout_helper.rb:246:in `form_for'
  app/views/filters/_form.html.erb:3:in `_b45b2ae2fba8a33ed854c14ac1956876'
  app/views/filters/edit.html.erb:3:in `_f35aa42ef6859ffae5b73ffa5586d845'
  app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
  lib/middleware/catch_json_parse_errors.rb:9:in `call'

Related issues

Related to Foreman - Bug #4553: Editing "miscellaneous" filter triggers: undefined method `pluralize' for nil:NilClassClosed2014-03-05
Is duplicate of Foreman - Bug #4557: "Undefined Method" is raised in FiltersHelper#resource_path when resource is defined in a namespaced pluginClosed2014-03-05

History

#1 Updated by Dominic Cleal over 5 years ago

  • Blocks Tracker #4552: New permissions/authorization system issues added

#2 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #4553: Editing "miscellaneous" filter triggers: undefined method `pluralize' for nil:NilClass added

#3 Updated by Dominic Cleal over 5 years ago

  • Blocks deleted (Tracker #4552: New permissions/authorization system issues)

#4 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #4557: "Undefined Method" is raised in FiltersHelper#resource_path when resource is defined in a namespaced plugin added

#5 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF