Project

General

Profile

Bug #4603

RBAC UI - plugin permissions not properly found

Added by Thomas McKay over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Users, Roles and Permissions
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The filters_helper is incorrectly assuming that all resources are in the main app. The fix is below

@ -19,6 +19,14 @ def search_path(type)
def resource_path(type)
return '' if type.nil?

-    send(type.pluralize.underscore + '_path')
+ #send(type.pluralize.underscore + '_path')
+
+ object_path = type.pluralize.underscore
+ if object_path.include?('/')
+ prefix, suffix = object_path.split('/', 2)
+ send(prefix).send(suffix + '_path')
+ else
+ send("#{object_path}_path")
+ end

Related issues

Is duplicate of Foreman - Bug #4557: "Undefined Method" is raised in FiltersHelper#resource_path when resource is defined in a namespaced pluginClosed2014-03-05

History

#1 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Bug #4557: "Undefined Method" is raised in FiltersHelper#resource_path when resource is defined in a namespaced plugin added

#2 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Duplicate

Fixes should be submitted as pull requests. Dupe of #4557.

Also available in: Atom PDF