Project

General

Profile

Bug #4636

Katello should extend the Redhat Model, vs the Operating System model

Added by Ohad Levy over 5 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The redhat model is the relevant model that we want to extend, leaving other os type.

see https://github.com/theforeman/foreman_content/blob/master/lib/content/engine.rb#L32 for old reference


Related issues

Is duplicate of Katello - Bug #6156: move OperatingsystemExtensions to RedhatExtensionsDuplicate2014-06-11

Associated revisions

Revision 7924fd56 (diff)
Added by Joseph Magen about 5 years ago

fixes #4636 - refactor OperatingsystemExtensions to RedhatExtensions and refactor MediumExtensions

Revision f3771616
Added by Justin Sherrill about 5 years ago

Merge pull request #4246 from isratrade/6156

fixes #4636 - refactor OperatingsystemExtensions to RedhatExtensions and refactor MediumExtensions

History

#1 Updated by Eric Helms about 5 years ago

  • Category set to 83
  • Target version set to 45
  • Difficulty set to easy
  • Triaged set to Yes

#2 Updated by Joseph Magen about 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Joseph Magen

#3 Updated by Ohad Levy about 5 years ago

  • Is duplicate of Bug #6156: move OperatingsystemExtensions to RedhatExtensions added

#4 Updated by Eric Helms about 5 years ago

  • Target version changed from 45 to 48

#5 Updated by Anonymous about 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:7924fd5645785eda8dc3144e458330dbd4900516.

#6 Updated by Eric Helms almost 5 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1112756

#7 Updated by Justin Sherrill almost 5 years ago

  • Bugzilla link changed from https://bugzilla.redhat.com/show_bug.cgi?id=1112756 to https://bugzilla.redhat.com/show_bug.cgi?id=1112816

#8 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF