Project

General

Profile

Bug #4652

error when running tests from ide

Added by Amos Benari over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Settings
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I get
/config/initializers/fix_cache.rb:10:in `<top (required)>': undefined method `value' for nil:NilClass (NoMethodError)
when running specific test from the ide (not rake task).


Related issues

Is duplicate of Foreman - Bug #4607: fix cache initialization sometimes failsDuplicate2014-03-10

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #4607: fix cache initialization sometimes fails added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Running the rake test first should populate the test DB, which should get around this bug (#4607).

#3 Updated by Dominic Cleal over 5 years ago

  • Category set to Settings
  • Status changed from Duplicate to Ready For Testing
  • Assignee set to Amos Benari
  • Target version set to 1.9.0
  • Legacy Backlogs Release (now unused) set to 4

#4 Updated by Marek Hulán over 5 years ago

  • Status changed from Ready For Testing to Closed

Closing manually, since the revision was referring to #4607

Also available in: Atom PDF