Project

General

Profile

Tracker #4656

Drop Ruby 1.8 support

Added by Dominic Cleal about 5 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

100%

Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Tracker for anything concerning Ruby 1.8.7 support, and being able to drop it. There are likely things in Foreman we can revert (gem pins, workarounds).

There was a short discussion on foreman-dev in 2013 about when we'd look to drop it:
https://groups.google.com/d/msg/foreman-dev/0TsJ9wxmUOQ/YpBdCi97ARgJ

The general consensus there and in other discussions has been to continue supporting 1.8 while it's been reasonable effort (pinning gems etc), and while none of our major dependencies (i.e. Rails, Fog) have dropped it. A move to Rails 4 would necessitate dropping 1.8.


Related issues

Related to Foreman - Bug #3369: rubyzip 1.0.0 breaks Ruby 1.8 buildClosed2013-10-18
Related to Foreman - Bug #3005: gettext 3.0.0 breaks Ruby 1.8 supportClosed2013-09-01
Related to Foreman - Bug #3167: gettext_i18n_rails 1.0.0 incompatible with gettext 2.xClosed2013-09-30
Related to Foreman - Bug #2808: nokogiri 1.6.0 incompatible with Ruby 1.8Closed2013-07-19
Related to Foreman - Bug #2385: Capybara 2.1.0 incompatible with Ruby 1.8Closed2013-04-10
Related to Foreman - Bug #2100: KS provisioning template regexp buffer overflowClosed2013-01-03
Related to Foreman - Bug #4828: Rake 10.2.0 breaks Ruby 1.8 compatibilityClosed2014-03-25
Related to Foreman - Bug #5214: Ancestry 2.1.0 dropped Ruby 1.8 supportClosed2014-04-16
Related to Foreman - Bug #5966: execjs 2.1.0 drops Ruby 1.8 compatibilityClosed2014-05-28
Related to Foreman - Bug #6533: rest-client 1.7.0 dropped Ruby 1.8 supportClosed2014-07-09
Related to Foreman - Bug #7013: apipie-rails 0.2.3 is incompatible with 1.8.7Closed2014-08-10
Has duplicate Foreman - Feature #7513: drop ruby 1.87 supportDuplicate2014-09-18
Blocks Foreman - Tracker #3157: Rails 4.1 upgrade tasksClosed2013-09-27

Blocked by Packaging - Feature #7227: Move Ubuntu 12.04 packages to Brightbox PPA with Ruby 1.9Closed2014-08-22
Blocks Foreman - Feature #7514: add foreman tasks into coreNew
Blocks Foreman - Refactor #7233: Revert Ruby 1.8 specificsClosed2014-08-22
Blocks Foreman - Refactor #8461: Replace UUIDTools with SecureRandom.uuidClosed2014-11-20

Associated revisions

Revision 40f0f9fc (diff)
Added by Dominic Cleal almost 5 years ago

refs #4656 - add Ruby 1.8.7 support warning

History

#1 Updated by Dominic Cleal about 5 years ago

#2 Updated by Dominic Cleal about 5 years ago

  • Plugins use deface < 1.0 at the moment, but >= 1.0 requires nokogiri ~> 1.6.0 which is incompatible with 1.8. We can then switch to deface 1.0 after dropping 1.8.

#3 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #3369: rubyzip 1.0.0 breaks Ruby 1.8 build added

#4 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #3005: gettext 3.0.0 breaks Ruby 1.8 support added

#5 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #3167: gettext_i18n_rails 1.0.0 incompatible with gettext 2.x added

#6 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #2808: nokogiri 1.6.0 incompatible with Ruby 1.8 added

#7 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #2385: Capybara 2.1.0 incompatible with Ruby 1.8 added

#8 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #2100: KS provisioning template regexp buffer overflow added

#9 Updated by Dominic Cleal about 5 years ago

Debian 6 (squeeze) and Ubuntu 12.04 (precise) both use 1.8.7 as default, but Debian 6 will be EOL soon (May 2014) and 12.04 will be supplanted by 14.04 shortly.

They're able to switch to 1.9.2/3 by default, but both ship Ruby 1.9 versions that aren't supported by Puppet upstream, so doing this can't really be recommended.

It seems that using Debian 7 and Ubuntu 14.04 as our primary versions for these distros would be a good cue to begin dropping 1.8 support (maybe Foreman 1.6 or equivalent).

#10 Updated by Dominic Cleal about 5 years ago

1.8 support will probably continue for the smart proxy and probably Hammer for longer, since they use the system Ruby 1.8.7 on EL6, rather than software collections.

The proxy has to load Puppet, which remains packaged for 1.8 (though they're talking about dropping support - how isn't clear, yet), while I think we used 1.8 for Hammer to reduce dependencies. Now SCL's released, using it for Hammer on EL6 might well be sensible.

#11 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #4828: Rake 10.2.0 breaks Ruby 1.8 compatibility added

#12 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #5214: Ancestry 2.1.0 dropped Ruby 1.8 support added

#13 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #5966: execjs 2.1.0 drops Ruby 1.8 compatibility added

#14 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #6533: rest-client 1.7.0 dropped Ruby 1.8 support added

#15 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #7013: apipie-rails 0.2.3 is incompatible with 1.8.7 added

#16 Updated by Dominic Cleal almost 5 years ago

  • Blocked by Feature #7227: Move Ubuntu 12.04 packages to Brightbox PPA with Ruby 1.9 added

#17 Updated by Dominic Cleal almost 5 years ago

Up for discussion again, possibly for Foreman 1.7: https://groups.google.com/forum/#!topic/foreman-dev/p48T8bQ21hY

Debian 6 has been deprecated as of 1.6, and will be dropped for 1.7. #7227 tracks how to handle Ubuntu 12.04.

#18 Updated by Dominic Cleal almost 5 years ago

#19 Updated by Ohad Levy over 4 years ago

#20 Updated by Ohad Levy over 4 years ago

#21 Updated by Ohad Levy over 4 years ago

  • Legacy Backlogs Release (now unused) set to 21

#22 Updated by Dominic Cleal over 4 years ago

#23 Updated by Dominic Cleal over 4 years ago

#24 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Closed
  • Target version set to 1.7.2
  • % Done changed from 0 to 100

#25 Updated by Dominic Cleal over 4 years ago

  • Blocks Refactor #8461: Replace UUIDTools with SecureRandom.uuid added

#26 Updated by Tomer Brisker 7 months ago

  • Category deleted (70)

Also available in: Atom PDF