Project

General

Profile

Bug #4685

Editing an organization in ~/organizations/<ord_id>-<org_name>/edit leads to traceback

Added by Jiří Mikulka about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When one wants to edit already created organization in WebUI, it fails with the following traceback:

NoMethodError
undefined method `parent_taxonomy_selected_location_path' for #<#<Class:0x007fd848ada3e0>:0x0000000c47f548>
app/views/taxonomies/_form.html.erb:8:in `block in app_views_taxonomies_form_html_erb__4288734552067943612_70283462707200'
app/helpers/layout_helper.rb:246:in `form_for'
app/views/taxonomies/_form.html.erb:3:in `_app_views_taxonomies__form_html_erb__4288734552067943612_70283462707200'
app/views/taxonomies/edit.html.erb:4:in `_app_views_taxonomies_edit_html_erb__2905390570401795523_103033240'
app/controllers/concerns/foreman/controller/taxonomies_controller.rb:67:in `block in edit'
app/models/taxonomy.rb:40:in `block in no_taxonomy_scope'
app/models/taxonomy.rb:47:in `block (2 levels) in as_taxonomy'
app/models/concerns/foreman/thread_session.rb:143:in `as_location'
app/models/taxonomy.rb:46:in `block in as_taxonomy'
app/models/concerns/foreman/thread_session.rb:108:in `as_org'
app/models/taxonomy.rb:45:in `as_taxonomy'
app/models/taxonomy.rb:39:in `no_taxonomy_scope'
app/controllers/concerns/foreman/controller/taxonomies_controller.rb:65:in `edit'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

Note: tested on katello/foreman-nightly

History

#1 Updated by Mike McCune about 8 years ago

  • Triaged set to Yes

#2 Updated by Mike McCune about 8 years ago

  • Triaged deleted (Yes)

#3 Updated by Ivan Necas about 8 years ago

  • Status changed from New to Duplicate
  • Triaged set to No

The issue is on Foreman side, http://projects.theforeman.org/issues/4712, closing this as duplicity

#4 Updated by Eric Helms almost 8 years ago

  • Triaged changed from No to Yes

#5 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#6 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF