Project

General

Profile

Bug #4756

Bad request errors are not properly displayed in the CLI

Added by David Davis about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

If you do the following in the code:

fail HttpErrors::BadRequest.new("This is an error")

Then you get this output in the CLI:

Error: 400 Bad Request

Even though the json has a valid error in it ("This is an error").


Related issues

Is duplicate of Hammer CLI - Bug #5215: "bad request" exceptions and their messages are not displayed to hammer userClosed2014-04-16

History

#1 Updated by Mike McCune about 8 years ago

  • Triaged set to Yes

#2 Updated by Mike McCune about 8 years ago

  • Triaged deleted (Yes)

#3 Updated by Mike McCune about 8 years ago

  • Assignee set to David Davis
  • Triaged set to Yes

#4 Updated by David Davis over 7 years ago

  • Is duplicate of Bug #5215: "bad request" exceptions and their messages are not displayed to hammer user added

#5 Updated by David Davis over 7 years ago

  • Status changed from New to Duplicate

#6 Updated by Eric Helms over 7 years ago

  • Legacy Backlogs Release (now unused) set to 13

#7 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#8 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF