Project

General

Profile

Bug #4828

Rake 10.2.0 breaks Ruby 1.8 compatibility

Added by Dominic Cleal about 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Rake 10.2.0 breaks Ruby 1.8 compatibility, it needs pinning.

Gem::InstallError: rake requires Ruby version >= 1.9.
An error occurred while installing rake (10.2.0), and Bundler cannot continue.
Make sure that `gem install rake -v '10.2.0'` succeeds before bundling.

Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 supportClosed

Associated revisions

Revision d59d2728 (diff)
Added by Dominic Cleal about 5 years ago

fixes #4828 - pin rake for Ruby 1.8 compatibility

Revision b33445ad (diff)
Added by Dominic Cleal about 5 years ago

fixes #4828 - pin rake for Ruby 1.8 compatibility

(cherry picked from commit d59d272874a0571fd768b2ff66bf3af1eef57488)

History

#1 Updated by Dominic Cleal about 5 years ago

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from Assigned to Ready For Testing

#3 Updated by Dominic Cleal about 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 9 to 4

#5 Updated by Dominic Cleal about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 4 to 17

Also available in: Atom PDF