Project

General

Profile

Bug #4830

Trends with no data should provide a warning message - e.g. No data yet

Added by Jan Hutař over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Trends
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When I specify range in Monitor -> Trends -> <my_architecture_trend>, it does not seem to apply to the graph.

I have this trend:

Fact Name    Display Name
architecture     Somename
Value    Display Name
x86_64    x86_64

and when I click at it, sub heading of the graph changes from "last 30 days" to, say, "last 15 days", but x-axe labels do not move or change. Also I have the Satellite 6 system installed only for ~5 days, so majority of the interval there have to be gap.

# rpm -qa | grep -e katello -e foreman
foreman-1.5.0.10-1.el6sat.noarch
rubygem-hammer_cli_katello-0.0.3-6.el6sat.noarch
foreman-ovirt-1.5.0.10-1.el6sat.noarch
foreman-selinux-1.5.0-0.develop.el6sat.noarch
katello-apache-1.0-1.noarch
ruby193-rubygem-foreman-tasks-0.4.0-5.el6sat.noarch
rubygem-katello_api-0.0.8-2.el6sat.noarch
katello-1.5.0-18.el6sat.noarch
foreman-proxy-1.5.3-1.el6sat.noarch
katello-ca-1.0-1.noarch
katello-certs-tools-1.5.5-1.el6sat.noarch
rubygem-hammer_cli_foreman-0.0.18-8.el6sat.noarch
katello-installer-0.0.30-1.el6sat.noarch
foreman-libvirt-1.5.0.10-1.el6sat.noarch
smqa-x3550m3-01.lab.eng.brq.redhat.com-foreman-client-1.0-1.noarch
rubygem-hammer_cli_foreman_tasks-0.0.1-4.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
foreman-vmware-1.5.0.10-1.el6sat.noarch
foreman-postgresql-1.5.0.10-1.el6sat.noarch
smqa-x3550m3-01.lab.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
foreman-compute-1.5.0.10-1.el6sat.noarch
rubygem-foreman_api-0.1.11-4.el6sat.noarch
ruby193-rubygem-katello-1.5.0-23.el6sat.noarch

Associated revisions

Revision e06167e0 (diff)
Added by Shimon Shtein about 4 years ago

Fixes #4830 - Added a new template to show when no trend data is collected.

History

#1 Updated by Dominic Cleal over 5 years ago

  • Category set to Trends

#2 Updated by Shimon Shtein over 4 years ago

  • Status changed from New to Need more information
  • Assignee set to Shimon Shtein

What are the exact steps to reproduce it?

#3 Updated by Shimon Shtein over 4 years ago

If it's possible, look at the HTML source of the graph. There should be a <div> with class "statistics-chart", I am interested in the value of the "data-series" attribute. Be aware, it contains the group labels that are shown under the graph, if they are sensitive, please substitute them.

#4 Updated by Jan Hutař over 4 years ago

Hi, looks like this was either already fixed or what I have seen was empty graph ('foreman-rake trends:counter' not run after trend was created) i.e. this:

&lt;div class="stats-well col-md-12"&gt;
&lt;h4 class="ca"&gt;Somename2&lt;/h4&gt;
&lt;h6 class="ca"&gt;last 30 days&lt;/h6&gt;
&lt;div class="statistics-chart stack" data-legend-options="external" data-series="[]" data-xaxis-label="" data-yaxis-label="Number of Hosts" id="trend_graph"&gt;&lt;/div&gt;
&lt;/div&gt;

In this case I would expect some notice in the graph or somewhere like "No data yet".

I have tested small trend (as per initial comment) with some data and it appears correctly:

&lt;div class="stats-well col-md-12"&gt;
&lt;h4 class="ca"&gt;Somename&lt;/h4&gt;
&lt;h6 class="ca"&gt;last 30 days&lt;/h6&gt;
&lt;div class="statistics-chart stack" data-legend-options="external" data-series="[{&quot;label&quot;:&quot;x86_64&quot;,&quot;href&quot;:&quot;/trends/2-x86_64&quot;,&quot;data&quot;:[[1424289552000,2],[1424289641000,2],[1424289683000,2]],&quot;color&quot;:&quot;#4572A7&quot;}]" data-xaxis-label="" data-yaxis-label="Number of Hosts" id="trend_graph"&gt;&lt;/div&gt;
&lt;/div&gt;

So if you are not willing to keep this bug for that "No data yet" notice in case there are no data, I'm OK if you close this bug as WORKSFORME or something.

#5 Updated by Jan Hutař over 4 years ago

Sorry for that escaped HTML. I have just pasted it and looks like some formatting was required :-/

#6 Updated by Ohad Levy about 4 years ago

  • Subject changed from when I specify range in Monitor -> Trends -> <my_architecture_trend>, it does not seem to apply to the graph to Trends with no data should provide a warning message - e.g. No data yet
  • Status changed from Need more information to New

#7 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2515 added
  • Pull request deleted ()

#8 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 63

#9 Updated by Shimon Shtein about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF