Project

General

Profile

Feature #4912

Katello and Foreman Host and System integration

Added by Mike McCune about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
hard
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

We need to better integrate Foreman Hosts and Katello Systems. This includes a series of work to do the following:

  • Rename Katello Systems to Hosts
  • Build a datamodel where Katello Hosts are an extension or joined to a Foreman Host
  • Build UI linking between Katello Hosts and Foreman Hosts
  • Ensure datamodel integrity such that hosts are created/updated/deleted in unison between Foreman and Katello
  • Ensure that when API calls (eg, subscription-manager) create registered hosts that there are corresponding hosts created in Foreman's datamodel

We will break this out into multiple issues but track the overall feature here.


Related issues

Related to Katello - Feature #6669: after lifecycle environment and content view are selected, default to associated puppet environment but have option to change itDuplicate2014-07-17
Is duplicate of Katello - Tracker #8161: Host UnificationRejected

History

#1 Updated by Mike McCune about 8 years ago

  • Description updated (diff)

#2 Updated by Bryan Kearney about 8 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1081697

#3 Updated by Eric Helms almost 8 years ago

  • Subject changed from [RFE] Katello and Foreman Host and System integration to Katello and Foreman Host and System integration
  • Legacy Backlogs Release (now unused) set to 14

#4 Updated by Eric Helms over 7 years ago

  • Legacy Backlogs Release (now unused) deleted (14)

#5 Updated by Eric Helms over 7 years ago

  • Related to Feature #6669: after lifecycle environment and content view are selected, default to associated puppet environment but have option to change it added

#6 Updated by Eric Helms almost 7 years ago

  • Status changed from New to Duplicate

#7 Updated by Eric Helms almost 7 years ago

#8 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF