Project

General

Profile

Bug #4955

Sync plan API bugs

Added by David Davis over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
API
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Some things I noticed in the sync plan API:

  • Some of the doc is wrong like it references products (e.g. param :id, :number, :desc => "product numeric identifier", :required => true; param :organization_id, :identifier, :desc => "Filter products by organization name or label", :required => true)
  • Show requires organization_id. AFAIK, we're only requiring organization_id on show if the ID is not unique across orgs

Related issues

Has duplicate Katello - Bug #4954: Deleting a sync plan via the CLI fails because of incorrect expected argumentDuplicate2014-03-29

History

#1 Updated by David Davis over 6 years ago

Also, delete and update require organization_id too. Probably should fix those as well.

#2 Updated by David Davis over 6 years ago

  • Has duplicate Bug #4954: Deleting a sync plan via the CLI fails because of incorrect expected argument added

#3 Updated by David Davis over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to David Davis

#5 Updated by David Davis over 6 years ago

  • Status changed from Assigned to Closed

#6 Updated by Eric Helms over 6 years ago

  • Triaged changed from No to Yes

#7 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF