Project

General

Profile

Bug #5000

UI label generation is slow and often gets out of sync with typing

Added by Mike McCune over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

For example, typing out:

"This is a test of the label system"

can end up with:

"This_is_t"

It seems to trip up if you tab off the field after typing or if your network connection is slow. Backspace and re-typing often can cause jumbled labels that don't equal the name

Associated revisions

Revision 834f0bdf (diff)
Added by Walden Raines over 6 years ago

Fixes #5000, generate labels client side

Revision 53e256aa
Added by Walden Raines over 6 years ago

Merge pull request #4005 from waldenraines/bug-5000

Fixes #5000, generate labels client side.

History

#1 Updated by Mike McCune over 6 years ago

  • Description updated (diff)

#2 Updated by Thomas McKay over 6 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1081072

#3 Updated by Ivan Necas over 6 years ago

Very often, when testing with remote machine, it seems the response come in different order than the requests, and the last one wins.

#4 Updated by Walden Raines over 6 years ago

  • Assignee changed from Partha Aji to Walden Raines

#5 Updated by Walden Raines over 6 years ago

  • Status changed from New to Assigned

#6 Updated by Walden Raines over 6 years ago

  • Status changed from Assigned to Ready For Testing

#7 Updated by Walden Raines over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:834f0bdf19ea73c05619e8da932404f06f3888b8.

#8 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF