Project

General

Profile

Bug #5142

repository create form sending up empty string which pulp errors on as feed

Added by Thomas McKay over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1086355
Page 11 Section 3.3 Step 6 - Clicking Save gives brief spinner but does not leave page. No error displayed in UI.

The 'feed' form param is getting sent as "" (empty string). This is reproducible by entering a URL value in the form and then clearing it. (The step doesn't mention URL so I pasted the previous path there before deleting it before form submission. No error in UI. Can see error state in /foreman_tasks/dynflow (See @jsherrill for debug)

Associated revisions

Revision cd41f287 (diff)
Added by Justin Sherrill over 6 years ago

fixes #5142 - fixing error on repo create with empty string

pulp does not treet empty string for feed urls the same as
nil. As a result repo creation would fail. This fixes the issue by doing 2 things:

a) convert empty string to nil at repo creation time
b) explicitly do not accept empty string in the url validator

Revision 1e1863cf
Added by Justin Sherrill over 6 years ago

Merge pull request #3969 from jlsherrill/repo_feed

fixes #5142 - fixing error on repo create with empty string

History

#1 Updated by Justin Sherrill over 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Justin Sherrill
  • Target version set to 43
  • Triaged set to Yes

#2 Updated by Justin Sherrill over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:cd41f287eba9ac0d2d0f5fa220e35beb078cd864.

#3 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF