Project

General

Profile

Feature #5203

Custom facts in foreman

Added by Matteo Cerutti over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

it would be nice if Foreman had the ability to declare custom static facts through the GUI.

The user would be provided with a simple interface through which they can define custom facts including default value and multiple choices.

One would then be able to choose the value of a fact let's say under the host edit section, just like one would do with the environment setting. Multiple choices could be offered via a drop-drown.

Alternatively, it would be handy if the global/host parameters had a drop-down style selection with predefined choices that the user can manage through the GUI.

Regards,
Matteo


Related issues

Is duplicate of Foreman - Feature #4127: Array, Boolean and other types support in "hostgroup parameters"Closed

History

#1 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Feature #4127: Array, Boolean and other types support in "hostgroup parameters" added

#2 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Duplicate

I'm marking this as a dupe of #4127, as I think the ideas mentioned there and in its related tickets would solve this for you too.

Also available in: Atom PDF