Project

General

Profile

Feature #5371

Facet search: support pagination

Added by Mike McCune about 8 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

See https://github.com/Katello/katello/pull/3805#issuecomment-37648249

We should support pagination in facet search to speed up initial load time.
----
Imported from https://trello.com/c/klGlRcJv/385-facet-search-support-pagination_

History

#1 Updated by Eric Helms about 7 years ago

  • Status changed from New to Duplicate
  • Triaged set to Yes

#3 Updated by Walden Raines about 7 years ago

  • Status changed from Duplicate to New

This isn't really a duplicate of #9729. For #9729 I plan on submitting a client side fix so we don't require these lines:

https://github.com/Katello/bastion/blob/master/app/assets/javascripts/bastion/components/nutupane-table.directive.js#L62-L68

which trigger a resize event for every row in the table. I agree that supporting pagination in facet search would also help to alleviate this issue but the main problem here is the aforementioned JS code.

#6 Updated by Eric Helms over 6 years ago

  • Status changed from New to Resolved

Elasticsearch has been removed as of Katello 2.4.0

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF