Project

General

Profile

Bug #5406

Trying to remove a content view from an environment it's not in results in nil errors

Added by David Davis about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
API
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I think this affects both remove_from_environment and remove_associations.


Related issues

Is duplicate of Katello - Bug #6848: Error when removing a content view from an environmentClosed2014-07-30

History

#1 Updated by David Davis about 8 years ago

unless @view.in_environment?(@environment)
  fail HttpErrors::BadRequest, _("Content view '%{view}s' not in environment '%{env}s'.") %
    {view: @view.name, environment: @environment.name}
end 

#2 Updated by Eric Helms almost 8 years ago

  • Difficulty set to easy
  • Triaged changed from No to Yes

#3 Updated by David Davis over 7 years ago

  • Status changed from New to Duplicate

#4 Updated by David Davis over 7 years ago

  • Is duplicate of Bug #6848: Error when removing a content view from an environment added

#5 Updated by Eric Helms over 7 years ago

  • Legacy Backlogs Release (now unused) set to 13

#6 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF