Project

General

Profile

Bug #5451

Repo discovery existing product list seems busted

Added by Justin Sherrill about 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When using repo discovery, on the creation screen, the drop down for products seems empty.


Related issues

Has duplicate Katello - Bug #5661: Repo discovery products list should only show custom products and indicate loadingDuplicate2014-05-10

Associated revisions

Revision dd75401e (diff)
Added by Eric Helms almost 5 years ago

Fixes #5451: Load only custom products for repo discovery.

Adds 'custom' param option to the products index API call in order
to retrieve non-red hat products. Updates the repo discovery creation
screen to pass custom so that users are only creating repositories
for existing custom products.

Revision a9a2a8c6 (diff)
Added by Eric Helms almost 5 years ago

Fixes #5451: Load only custom products for repo discovery.

Adds 'custom' param option to the products index API call in order
to retrieve non-red hat products. Updates the repo discovery creation
screen to pass custom so that users are only creating repositories
for existing custom products.

Revision ec2d196a
Added by Eric Helms almost 5 years ago

Merge pull request #4308 from ehelms/fixes-5451

Fixes #5451: Load only custom products for repo discovery.

Revision c8ba118a
Added by Eric Helms almost 5 years ago

Merge pull request #4308 from ehelms/fixes-5451

Fixes #5451: Load only custom products for repo discovery.

History

#1 Updated by Eric Helms almost 5 years ago

  • Target version set to 45
  • Triaged changed from No to Yes

Recent testing, this appears to be just lag loading the products list from the API as it is currently loading ALL products (Red Hat included) and should only be listing custom products.

#2 Updated by Eric Helms almost 5 years ago

  • Target version changed from 45 to 48

#3 Updated by Eric Helms almost 5 years ago

  • Is duplicate of Bug #5661: Repo discovery products list should only show custom products and indicate loading added

#4 Updated by Eric Helms almost 5 years ago

  • Status changed from New to Duplicate

#5 Updated by Eric Helms almost 5 years ago

  • Category set to Web UI
  • Status changed from Duplicate to Closed
  • Assignee set to Eric Helms

#6 Updated by Eric Helms almost 5 years ago

  • Is duplicate of deleted (Bug #5661: Repo discovery products list should only show custom products and indicate loading)

#7 Updated by Eric Helms almost 5 years ago

  • Has duplicate Bug #5661: Repo discovery products list should only show custom products and indicate loading added

#8 Updated by Eric Helms almost 5 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1112792

Also available in: Atom PDF