Project

General

Profile

Bug #5454

Updating organization label doesn't work

Added by Thomas McKay about 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
API
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1089996
Description of problem:

When running update on org on api endpoint, label present in json causes candlepin to throw errors.

Version-Release number of selected component (if applicable):
Version 1.5.0-19.el6sat

Steps to Reproduce:

curl -X PUT -k -u admin:changeme -H "Content-Type: application/json" https://qetello02.usersys.redhat.com/api/v2/organizations/550 -d '{"organization": {"label": "hIxwUvCnUHowVjwnqedD", "description": "ollIHcITnDinXqIGhGoA", "name": "38343473775053308715"}}'

Actual results: {
"error": {"message":"Katello::Resources::Candlepin::CandlepinResource: 404 Resource Not Found {\"displayMessage\":\"Organization with id hIxwUvCnUHowVjwnqedD could not be found.\",\"requestUuid\":\"04729c92-3710-46f6-be9d-e5d7c94ddc6f\"} (GET /candlepin/owners/hIxwUvCnUHowVjwnqedD/servicelevels)"}
}

Expected results: {"organization":{"ancestry":null,"apply_info_task_id":null,"created_at":"2014-04-22T09:40:23Z","default_info":{"system":[],"distributor":[]},"deletion_task_id":null,"description":"ollIHcITnDinXqIGhGoA","id":550,"ignore_types":[],"label":"59533697327709441536","name":"38343473775053308715","owner_auto_attach_all_systems_task_id":null,"title":"38343473775053308715","updated_at":"2014-04-22T09:54:20Z","service_levels":[],"service_level":null}}

History

#1 Updated by Thomas McKay about 5 years ago

  • Assignee changed from Bryan Kearney to dustin tsang
  • Triaged set to Yes

#2 Updated by Thomas McKay about 5 years ago

Note: Labels are not allowed to be updated, once created they are permanent. The error is that hammer (and/or the api, and/or apipie) is allowing label to be passed into update. This are should be rejected (or ignored).

#3 Updated by dustin tsang about 5 years ago

  • Status changed from New to Closed

Closing as "Not a Bug":

Hi Adam, closing as "not a bug". The behavior is correct since Satelite6 uses the label as human-readable ids. Labels should also be immutable.

#4 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF