Project

General

Profile

Bug #5466

Latest passenger update broke SELinux file contexts

Added by Lukas Zapletal about 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
General Foreman
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The path has changed.

type=AVC msg=audit(1398675061.586:531): avc:  denied  { execute_no_trans } for  pid=25069 comm="httpd" path="/usr/lib64/ruby/site_ruby/1.8/x86_64-linux/agents/PassengerWatchdog" dev=dm-0 ino=293908 scontext=unconfined_u:system_r:httpd_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file

Related issues

Related to SELinux - Bug #5487: cant run with SELinix in enforcing after upgrade to 1.5RC2Closed2014-04-29

Associated revisions

Revision 0e094fe2 (diff)
Added by Lukas Zapletal about 5 years ago

fixes #5466 - added new passenger file context path

History

#2 Updated by Dominic Cleal about 5 years ago

  • Legacy Backlogs Release (now unused) set to 4

#3 Updated by Anonymous about 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 4 to 17

#5 Updated by Dominic Cleal about 5 years ago

  • Related to Bug #5487: cant run with SELinix in enforcing after upgrade to 1.5RC2 added

Also available in: Atom PDF