Project

General

Profile

Bug #5573

Statistics link for OS results in field 'os_description' not recognized for searching

Added by Edwin Starkey about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Statistics
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

To reproduce, view the 'All hosts' page, then enter a filter such as:
os_description="RHEL Server 6.4"

This error is displayed:
Field 'os_description' not recognized for searching!

When you view the Statistics page and click an element of the "OS Distribution" pie chart, you are directed to the 'All hosts' page with the aforementioned filter.

This functionality used to work in a previous version. Sorry, I don't remember which one, probably 1.3.


Related issues

Related to Foreman - Bug #8043: Statistics link to OS is wrongClosed2014-10-23

Associated revisions

Revision 7c3c0594 (diff)
Added by Ori Rabin over 4 years ago

Fixes #5573 - os search definitions for host available in unattended=false mode

Revision f2ff7dc4 (diff)
Added by Ori Rabin over 4 years ago

Fixes #5573 - os search definitions for host available in unattended=false mode

(cherry picked from commit 7c3c0594afc76abbd6e684ef24c683d9d65e760e)

History

#1 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Need more information

Do you have :unattended set to true or false in /etc/foreman/settings.yaml?

#2 Updated by Edwin Starkey about 5 years ago

The 'unattended' setting is false.

#3 Updated by Dominic Cleal about 5 years ago

  • Subject changed from Field 'os_description' not recognized for searching to Statistics link for OS results in field 'os_description' not recognized for searching
  • Status changed from Need more information to New
  • Difficulty set to trivial

Thanks, that's what I suspected.. seems the OS related search definitions are only in the unattended=true section of app/models/concerns/hostext/search.rb, but probably shouldn't be.

#4 Updated by Ori Rabin almost 5 years ago

  • Is duplicate of Bug #8043: Statistics link to OS is wrong added

#5 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of deleted (Bug #8043: Statistics link to OS is wrong)

#6 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #8043: Statistics link to OS is wrong added

#7 Updated by Dominic Cleal almost 5 years ago

It's not exactly a duplicate, but maybe we can fix it at the same time. This only happens in unattended=false mode, which exposes different OS search options.

#8 Updated by Ori Rabin over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Ori Rabin

#9 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/1946 added
  • Pull request deleted ()

#10 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 21

#11 Updated by Ori Rabin over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF