Project

General

Profile

Bug #5625

undefined method `default_environment' for nil:NilClass when creating a system(content host) where environment other than Library is created and a content view is created

Added by dustin tsang about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

undefined method `default_environment' for nil:NilClass

Steps:
1. new system no CV or Environments
2. create a dev life cycle environment
3. create a content view and publish for just Library
4. activation key created with Library and Default View
5. send a Post to create a System:
Processing by Katello::Api::V2::SystemsController#create as application/json;version=2
Parameters: {"name"=>"foobar", "facts"=>"[FILTERED]", "organization_id"=>"ACME_Corporation", "type"=>"system", "api_version"=>"v2", "system"=>{"name"=>"foobar", "type"=>"system", "facts"=>"[FILTERED]"}}

Result: script/rails:6:in `<main>'
Completed 500 Internal Server Error in 37.7ms (Views: 0.8ms | ActiveRecord: 2.8ms)
With body: {"displayMessage":"undefined method `default_environment' for nil:NilClass","errors":["undefined method `default_environment' for nil:NilClass"]}


Related issues

Is duplicate of Katello - Bug #6082: registering a client without passing env and org raises undefined method errorClosed2014-06-05

History

#1 Updated by Eric Helms almost 8 years ago

  • Target version set to 45
  • Legacy Backlogs Release (now unused) set to 13
  • Triaged changed from No to Yes

#2 Updated by Eric Helms almost 8 years ago

  • Is duplicate of Bug #6082: registering a client without passing env and org raises undefined method error added

#3 Updated by Eric Helms almost 8 years ago

  • Status changed from New to Duplicate

#4 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF