Project

General

Profile

Bug #5634

Users using apache sso are redirected to /users/login at session timeout

Added by Stephen Benjamin about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Authentication
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When my session expires, I get redirected to /users/login. I should probably get redirected to /users/extlogin instead.

I see where it's theoretically supposed to happen in app/controllers/concerns/foreman/controller/session.rb, but get_sso_method is returning nil, so it never calls the SSO provider's expiration_url and uses the default instead.

Configured using the instructions in the manual.

Started GET "/" for 10.7.13.21 at 2014-05-08 17:03:01 +0200
Processing by DashboardController#index as HTML
Session for Stephen Benjamin is expired.
Unknown SSO method
Redirected to https://gatebuilder.bitbin.de/users/login
Filter chain halted as :session_expiry rendered or redirected
Completed 302 Found in 85ms (ActiveRecord: 81.7ms)

Associated revisions

Revision fae8b987 (diff)
Added by Stephen Benjamin over 4 years ago

fixes #5634 - save sso_method on session expiry

Revision 8a4e0b3c (diff)
Added by Stephen Benjamin over 4 years ago

fixes #5634 - save sso_method on session expiry

(cherry picked from commit fae8b987a8fb329d3cc6a9243e967861d7f5d198)

History

#1 Updated by Jan Pazdziora about 5 years ago

The problem seems to be -- even logout does not work properly anymore. If you logout, you should get to /users/extlogout for one-click re-login.

This used to work when we've introduced the feature so there is some regression there.

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Stephen Benjamin
  • Target version set to 1.8.3

#3 Updated by Dmitri Dolguikh about 5 years ago

  • Target version changed from 1.8.3 to 1.8.2

#4 Updated by Dmitri Dolguikh about 5 years ago

  • Target version changed from 1.8.2 to 1.8.1

#5 Updated by Dmitri Dolguikh about 5 years ago

  • Target version changed from 1.8.1 to 1.8.0

#6 Updated by Dmitri Dolguikh almost 5 years ago

  • Target version changed from 1.8.0 to 1.7.5

#7 Updated by Dmitri Dolguikh almost 5 years ago

  • Target version changed from 1.7.5 to 1.7.4

#8 Updated by Dmitri Dolguikh almost 5 years ago

  • Target version changed from 1.7.4 to 1.7.3

#9 Updated by Dominic Cleal almost 5 years ago

  • Target version changed from 1.7.3 to 1.7.2

#10 Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/foreman/pull/1429 added

#11 Updated by Stephen Benjamin over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#12 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 21

Also available in: Atom PDF