Project

General

Profile

Actions

Bug #5692

closed

Puppet environment counters not updated

Added by michael beemer almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

The environment dashboard server count doesn't update. Please see the screenshot for an example.

[[https://groups.google.com/forum/?fromgroups#!topic/foreman-users/knnR2G8OZYw]]


Files

environment.PNG View environment.PNG 13.8 KB michael beemer, 05/13/2014 12:54 PM

Related issues 9 (0 open9 closed)

Related to Foreman - Bug #6210: the config groups page + puppet environments page not displaying correct numbers of hosts and host groupsDuplicateTomer Brisker06/13/2014Actions
Related to Foreman - Bug #6813: Negative Hosts in Operating Systems viewDuplicateTomer Brisker07/29/2014Actions
Related to Foreman - Bug #7246: Remove counter workaround for #5692 on upgrade to rails 4.xRejected08/25/2014Actions
Related to Foreman - Bug #7247: Create migration to fix incorrect counts caused by #5692 and related bugsClosedTomer Brisker08/25/2014Actions
Related to Foreman - Bug #10133: Massive db deadlocks in postgres from hosts_counter updates with counter_cache_fix.rbClosedTomer Brisker04/14/2015Actions
Related to Foreman - Bug #11051: OS host counters inaccurate after host deletionRejectedTomer Brisker07/08/2015Actions
Related to Foreman - Bug #11444: Domains page shows negative number of hostsClosedTomer Brisker08/21/2015Actions
Has duplicate Foreman - Bug #6716: Wrong hosts count on environment pageDuplicate07/22/2014Actions
Has duplicate Foreman - Bug #7769: Negative number of hostsDuplicate10/01/2014Actions
Actions #1

Updated by Dominic Cleal almost 10 years ago

  • Subject changed from Foreman 1.5 Puppet Environments to Puppet environment counters not updated
  • translation missing: en.field_release set to 16
Actions #2

Updated by Dominic Cleal almost 10 years ago

  • Target version set to 1.8.2
Actions #3

Updated by Dominic Cleal over 9 years ago

  • translation missing: en.field_release deleted (16)
Actions #4

Updated by Anonymous over 9 years ago

  • Target version changed from 1.8.2 to 1.8.1
Actions #5

Updated by Dominic Cleal over 9 years ago

  • Related to Bug #6210: the config groups page + puppet environments page not displaying correct numbers of hosts and host groups added
Actions #6

Updated by Dominic Cleal over 9 years ago

Linked #6210 which is likely a duplicate, or a very similar issue.

Actions #7

Updated by Stephen Benjamin over 9 years ago

I'm almost certain it's a duplicate, because I've noticed myself now in a few places that the counter caches are fragile. When writing directly to the DB, they don't get updated, and I have a feeling there's something else fishy going on. I doubt it's simple.

What do you think about a rake task that will at least correct the wrong counts until we figure it out?

Actions #8

Updated by Dominic Cleal over 9 years ago

Stephen Benjamin wrote:

I'm almost certain it's a duplicate, because I've noticed myself now in a few places that the counter caches are fragile. When writing directly to the DB, they don't get updated, and I have a feeling there's something else fishy going on. I doubt it's simple.

What do you think about a rake task that will at least correct the wrong counts until we figure it out?

Can do, if it can be done simply. I think having this will be useful anyway.

Actions #9

Updated by Dominic Cleal over 9 years ago

  • Target version deleted (1.8.1)
Actions #10

Updated by Dominic Cleal over 9 years ago

  • Has duplicate Bug #6716: Wrong hosts count on environment page added
Actions #11

Updated by Dominic Cleal over 9 years ago

  • Related to Bug #6813: Negative Hosts in Operating Systems view added
Actions #12

Updated by Tomer Brisker over 9 years ago

  • Assignee set to Tomer Brisker
  • Target version set to 1.7.5
Actions #13

Updated by Dominic Cleal over 9 years ago

  • Status changed from New to Assigned
Actions #14

Updated by Tomer Brisker over 9 years ago

  • Status changed from Assigned to Duplicate
Actions #15

Updated by Tomer Brisker over 9 years ago

  • Status changed from Duplicate to Assigned
Actions #16

Updated by The Foreman Bot over 9 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/1690 added
  • Pull request deleted ()
Actions #17

Updated by Bryan Kearney over 9 years ago

  • Bugzilla link set to 1128069
Actions #18

Updated by Anonymous over 9 years ago

  • Target version changed from 1.7.5 to 1.7.4
Actions #19

Updated by Tomer Brisker over 9 years ago

  • Related to Bug #7246: Remove counter workaround for #5692 on upgrade to rails 4.x added
Actions #20

Updated by Tomer Brisker over 9 years ago

  • Related to Bug #7247: Create migration to fix incorrect counts caused by #5692 and related bugs added
Actions #21

Updated by Anonymous over 9 years ago

  • Target version changed from 1.7.4 to 1.7.3
Actions #22

Updated by Anonymous over 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #23

Updated by Dominic Cleal over 9 years ago

  • translation missing: en.field_release set to 22
Actions #24

Updated by Dominic Cleal over 9 years ago

  • Has duplicate Bug #7769: Negative number of hosts added
Actions #25

Updated by Anonymous about 9 years ago

Spam deleted by administrator.

Actions #26

Updated by Tomer Brisker almost 9 years ago

  • Related to Bug #10133: Massive db deadlocks in postgres from hosts_counter updates with counter_cache_fix.rb added
Actions #27

Updated by Dominic Cleal over 8 years ago

  • Related to Bug #11051: OS host counters inaccurate after host deletion added
Actions #28

Updated by Dominic Cleal over 8 years ago

  • Related to Bug #11444: Domains page shows negative number of hosts added
Actions

Also available in: Atom PDF