Project

General

Profile

Feature #5727

externalNodes in JSON via API

Added by Martin Matuška almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We are seriously missing the functionality to look up parameters via API the way they appear in the kickstart file.
Currently we need to look up the host, then its hostgroup, then all parent hostgroups, then the domain, then the operating system, etc.

This results in many API calls by looking for a single parameter.

It would be really great to be able to lookup all or just a single parameter this way.


Related issues

Is duplicate of Foreman - Feature #3220: API for "rendered" view of host parameters, taking into account inheritanceNew2013-10-08

History

#1 Updated by Martin Matuška almost 5 years ago

To be more precise, I want the output of externalNodes in JSON format via API :)

#2 Updated by Martin Matuška almost 5 years ago

  • Subject changed from Kickstart parameters lookup via API to externalNodes in JSON via API

#3 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Feature #3220: API for "rendered" view of host parameters, taking into account inheritance added

#4 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Duplicate

Hm, yep. Tracked as #3220.

Also available in: Atom PDF