Project

General

Profile

Bug #5801

updating the host collection limit below to already added content-host should throw a validation error

Added by Brad Buckingham about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1098418
Description of problem:
I've created a host collection with content-host limit 10. And I've successfully added two content host in the selected collection.

Later, when I tried to reduce the limit to '1' which is less than the already added number of hosts, it was correctly updated and notification says: Host collection updated.

But when I navigate away and come back on same page then found the system limit was still set to what it was originally i.e. 10 in this case.

So ideally, UI should throw a validation error if I set the limit below to already added host.

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140508.1

  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.7-1.el6_5.noarch
  • candlepin-scl-1-5.el6_4.noarch
  • candlepin-scl-quartz-2.1.5-5.el6_4.noarch
  • candlepin-scl-rhino-1.7R3-1.el6_4.noarch
  • candlepin-scl-runtime-1-5.el6_4.noarch
  • candlepin-selinux-0.9.7-1.el6_5.noarch
  • candlepin-tomcat6-0.9.7-1.el6_5.noarch
  • elasticsearch-0.90.10-4.el6sat.noarch
  • foreman-1.6.0.7-1.el6sat.noarch
  • foreman-compute-1.6.0.7-1.el6sat.noarch
  • foreman-gce-1.6.0.7-1.el6sat.noarch
  • foreman-libvirt-1.6.0.7-1.el6sat.noarch
  • foreman-ovirt-1.6.0.7-1.el6sat.noarch
  • foreman-postgresql-1.6.0.7-1.el6sat.noarch
  • foreman-proxy-1.6.0.4-1.el6sat.noarch
  • foreman-selinux-1.5.0-0.develop.el6sat.noarch
  • foreman-vmware-1.6.0.7-1.el6sat.noarch
  • katello-1.5.0-22.el6sat.noarch
  • katello-ca-1.0-1.noarch
  • katello-certs-tools-1.5.5-1.el6sat.noarch
  • katello-installer-0.0.37-1.el6sat.noarch
  • openldap-2.4.23-32.el6_4.1.x86_64
  • pulp-katello-plugins-0.2-1.el6sat.noarch
  • pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
  • pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
  • pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
  • pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
  • pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
  • pulp-server-2.3.1-0.4.beta.el6sat.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
  • ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
  • ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
  • rubygem-hammer_cli-0.1.0-12.el6sat.noarch
  • rubygem-hammer_cli_foreman-0.1.0-12.el6sat.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.2-5.el6sat.noarch
  • rubygem-hammer_cli_katello-0.0.3-22.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create host collection with limit 10
2. added two content-host to create collection in step1
3. now update the collection limit to 1

Actual results:
limit was correctly updated and notification says: Host collection updated.
But when I navigate away and come back on same page then found the system limit was still set to what it was originally

Expected results:
UI should throw validation error.

Additional info:
no errors in production.log

Associated revisions

Revision 58a5e3d3 (diff)
Added by Brad Buckingham about 5 years ago

fixes #5801 - host collection ui - update errors should be shown on UI

The validations were being executed; however, the errors were not
being returned to the client due to how update_attributes was
being used.

Now (for example), if a user has 3 content hosts in a collection
and they try to set the max content hosts to 2, they will get an
error back.

Revision 09825178
Added by Brad Buckingham about 5 years ago

Merge pull request #4154 from bbuckingham/issue-5801

fixes #5801 - host collection ui - update errors should be shown on UI

History

#1 Updated by Brad Buckingham about 5 years ago

  • Assignee set to Brad Buckingham
  • Triaged set to Yes

#2 Updated by Brad Buckingham about 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:58a5e3d38e16db01a7f45f76ed364c82521f6f96.

#3 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF