Project

General

Profile

Bug #5829

hammer product info does not accept --id argument

Added by Brad Buckingham over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1096320
Description of problem:
When trying to get information about a product the hammer product info command does not accept the --id argument

Version-Release number of selected component (if applicable):
  1. hammer --version
    hammer (0.1.0) * hammer_cli_foreman (0.1.0) * hammer_cli_katello (0.0.3)

How reproducible:
Aways

Steps to Reproduce:
1. hammer product info --id=<product_id> --organization-id=<org_id>

Actual results:
The command fail with the error: Error: Unrecognised option '--id'

Expected results:
The command accepts the --id argument and show the product information

Additional info:
hammer product info help does not show any other argument except -h, --help

  1. hammer product info --help
    Usage:
    hammer product info [OPTIONS]

Options:
-h, --help print help

History

#1 Updated by Brad Buckingham over 6 years ago

  • Triaged set to Yes

#2 Updated by Tomáš Strachota over 6 years ago

  • Status changed from New to Assigned
  • Assignee changed from Adam Price to Tomáš Strachota

#3 Updated by Tomáš Strachota over 6 years ago

  • Status changed from Assigned to Closed

This seems to be fixed in hammer-0.1.1 and hammer_cli_foreman-0.1.1.

#4 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF