Project

General

Profile

Bug #5867

Cannot Import Puppet Envioronments

Added by Paul Calabro over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I'm currently unable to import Puppet Environments. When doing so, I receive the following error:

Warning!

ERF12-4115 [ProxyAPI::ProxyException]: Unable to get classes from Puppet for development_alaa_testing ([RestClient::NotAcceptable]: 406 Not Acceptable) for proxy https://puppetmaster01.<some_domain>:8443/puppet

ProxyAPI::ProxyException

My /etc/puppet.conf is attached (sanitized).

proxy.log shows the following:

E, [2014-05-21T20:09:33.008251 #5973] ERROR -- : Failed to show puppet classes: no 'environments' in {:current_environment=>#<Puppet::Node::Environment:0x7f16d3e599d0 @watching=true, @config_version=nil, @name=:"*root*", @manifest="/", @modulepath=[]>, :root_environment=>#<Puppet::Node::Environment:0x7f16d3e599d0 @watching=true, @config_version=nil, @name=:"*root*", @manifest="/", @modulepath=[]>} at top of []

Please let me know if you need anything else.

Best,
Paul

puppet.conf puppet.conf 2.43 KB Paul Calabro, 05/22/2014 12:45 AM

Related issues

Is duplicate of Smart Proxy - Bug #5856: Cannot import environments, classes even with foreman 1.5.0Closed2014-05-21

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #5856: Cannot import environments, classes even with foreman 1.5.0 added

#2 Updated by Dominic Cleal over 5 years ago

Thanks for the report, we're tracking this in #5856.

#3 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF