Project

General

Profile

Bug #5916

Users created without an email address are broken

Added by Anonymous about 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I think I can duplicate it by creating a user without an initial email address configured. If I log in as the user I get prompted to add an email address which seems to work, but if I can't see things that my role should let me (having viewer and manager won't let me see Configure or Infrastructure on the top menu) and when I try to make the user an admin I get the following:

Creating the user with an email address when initially configuring them seems to make things work as expected. This was all using INTERNAL for the auth mechanism

Error
required lock: #<ForemanTasks::Lock:0x0000000b888c58> conflicts wiht [#<ForemanTasks::Lock id: 17, task_id: "5d30b01f-ced1-42ca-a10b-0659c704cd6d", name: "read", resource_type: "User", resource_id: 3, exclusive: true>]

If you feel this is an error with Foreman itself, please open a new issue with Foreman ticketing system, You would probably need to attach the Full trace and relevant log entries.
ForemanTasks::Lock::LockConflict
required lock: #<ForemanTasks::Lock:0x0000000b888c58> conflicts wiht [#<ForemanTasks::Lock id: 17, task_id: "5d30b01f-ced1-42ca-a10b-0659c704cd6d", name: "read", resource_type: "User", resource_id: 3, exclusive: true>]
app/controllers/users_controller.rb:40:in `update'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

History

#1 Updated by Dominic Cleal almost 8 years ago

  • Project changed from Foreman to foreman-tasks

Unable to reproduce the first part of the bug report in Foreman, the second half is something to do with foreman-tasks.

#2 Updated by Ivan Necas over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF